Go Back   The Navara Forum > General Discussions > Main Forum

Reply
 
Thread Tools Display Modes

  #11  
Old 20-09-2015, 12:29 PM
bods's Avatar
bods bods is offline
Advanced Member
 
Join Date: Sep 2010
Location: Orelia, WA
Posts: 4,948
Default

Did you drive it without the trailer connected and it has gone out, or just started the motor? 10 micron is still pretty fine filtration along with the factory filter. You would have to see what sort of fuel flow rate the v9x has.. from looking at the donaldson site, the flow rate of that filter is 115lph from memory. If that is close to what the v9x flows, there's a very good chance that under high engine load it could be restricting the fuel system and the engine light is to indicate a "blocked" fuel filter... I wonder if the service manual has anything on fuel flow rate for that motor...

Make that the donaldson flows 114lph. I have a stanadyne fuel manager fm100 on my d22 which is rated 30 micron and flows up to 300lph, so the flow rate on that donaldson could very likely be your issue...

Last edited by bods; 20-09-2015 at 12:33 PM.
Reply With Quote
Sponsored Links
Reply

Tags
engine, engine light, yd25

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 06:03 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
| Home | Register | FAQ | Members List | Calendar | Today's Posts | Search | New Posts |