Go Back   The Navara Forum > Tech Talk > General Tech Talk

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next

Over heating problem
  #1  
Old 08-01-2018, 01:13 PM
Steviej Steviej is offline
Junior Member
 
Join Date: Jan 2018
Location: Australia
Posts: 6
Default Over heating problem

Hi all. I have a 2011 navara frontier import to Australia with 145,000 miles on it. I had a mobile mechanic come over to give me a road worthy certificate and blew the coolant out of the radiator with out my knowing( i wasn't there but my oldest boy watched him open the radiator cap and blow coolant everywhere when starting it). Not knowing this i drove it afterwards and had the temp gauge rise to below cooking point but not in the red. Since that time i have replaced the thermostat, entire coolant flush and oil change with filter. The temp gauge sits on the usual temp(just below the half way mark) until i do 110 kmh which is when the temp slowly moves up but once i drop back down to 80kmh it cools back down to normal temp. Ive bled the coolant system by the old way of a funnel in the radiator with the coolant level higher than any part of the engine but after 40 mins of running im still getting air bubbles. Engine runs happy and no smoke of any sort from the exhaust. Air con works flat stick but heater doesn't. Its a d40 frontier spain produced model. Help me out guys
Reply With Quote
Sponsored Links
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 04:22 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
| Home | Register | FAQ | Members List | Calendar | Today's Posts | Search | New Posts |