Go Back   The Navara Forum > D22 > D22 Engine

Reply
 
Thread Tools Display Modes

ZD30 CEL & Blue Smoke
  #1  
Old 17-12-2017, 12:05 AM
bencowling bencowling is offline
Junior Member
 
Join Date: Dec 2017
Location: Sydney, Australia
Posts: 4
Default ZD30 CEL & Blue Smoke

Hey, new to the forums!

Just recently bought a 2004 D22 DX Navara 3.0L. Has had a lot of mechanical work done to it and was running A1 until I was driving home yesterday when I noticed the CEL had come on. Diesel was getting low so went and filled it up and made it home. I have cleaned out the fuel filter and that didn't fix it. It has intermittent loss of power and will mostly not rev above 2000-2500 revs as it will become very sputtery and blow large amounts of blue smoke.

Mechanical Work Done:
- New fan belt and tensioner pulley
-New motor mounts
-New turbo
- New centre bearing
- New rear main oil seal
- reco gearbox
- new clutch
- new starter motor
- EGR block and swirl mod
+ a few other things

Any advice on what I can do would be great! Cheers

Edit: Will no longer rev above 1500 RPM, runs extremely rough and blows a large amount of blue smoke.

Last edited by bencowling; 17-12-2017 at 02:56 AM. Reason: Updating Situation
Reply With Quote
Sponsored Links

  #2  
Old 17-12-2017, 04:17 AM
tweak'e's Avatar
tweak'e tweak'e is offline
Advanced Member
 
Join Date: Oct 2008
Location: New Zealand
Posts: 4,565
Garage
Default

first thing to do is check for error codes.

blue smoke is typically oil. i would have a quick look at turbo and check how much oil is in the intake.
__________________
D22 ZD30 egr+butterfly mod, 2" lift extra leaf springs, enk-tek dump pipe, 2.5" exhaust.
D23 no mods.......yet.
single cab workhorse, to muddy to clean
Reply With Quote

  #3  
Old 17-12-2017, 05:27 AM
bencowling bencowling is offline
Junior Member
 
Join Date: Dec 2017
Location: Sydney, Australia
Posts: 4
Default

Is there an easy way to check for codes or do I need a scanning tool?
Reply With Quote

  #4  
Old 17-12-2017, 06:06 AM
tweak'e's Avatar
tweak'e tweak'e is offline
Advanced Member
 
Join Date: Oct 2008
Location: New Zealand
Posts: 4,565
Garage
Default

there is a very easy way to check the codes. instructions on here somewhere.
__________________
D22 ZD30 egr+butterfly mod, 2" lift extra leaf springs, enk-tek dump pipe, 2.5" exhaust.
D23 no mods.......yet.
single cab workhorse, to muddy to clean
Reply With Quote

  #5  
Old 17-12-2017, 09:01 AM
bencowling bencowling is offline
Junior Member
 
Join Date: Dec 2017
Location: Sydney, Australia
Posts: 4
Default

Codes I have pulled (I think I got all of them):

0707 - Injection pump injection timing control
0406 - Intake air volume VNC system
0104 - Vehicle Speed Sensor
0208 - Cooling Fan Control
0407 - Crankshaft Position Sensor
0905 - Intake air pressure sensor
Reply With Quote

  #6  
Old 18-12-2017, 05:48 AM
tweak'e's Avatar
tweak'e tweak'e is offline
Advanced Member
 
Join Date: Oct 2008
Location: New Zealand
Posts: 4,565
Garage
Default

i would clear the codes, run the ute then re check and see what comes up.

those codes sounds like someones had the engine disconnected eg while working on it, and didn't clear the coses after working on it.

if all those codes do come back up, it sounds more like a bad earth (or one left disconnected) or possible wiring loom issue.
__________________
D22 ZD30 egr+butterfly mod, 2" lift extra leaf springs, enk-tek dump pipe, 2.5" exhaust.
D23 no mods.......yet.
single cab workhorse, to muddy to clean
Reply With Quote

  #7  
Old 18-12-2017, 10:27 AM
bencowling bencowling is offline
Junior Member
 
Join Date: Dec 2017
Location: Sydney, Australia
Posts: 4
Default

It hadn't been worked on in the time that i've had it and has been driven for approximately 1000km's atleast that I know of since had been worked on. CEL came on mid drive. I posted a video to youtube of me starting and running the ute so you can have a better idea of what it's doing. Found some oil in the intake shown in video and small amount of shaft play.
https://youtu.be/oMwJTnpHDDM
Reply With Quote
Reply

Tags
blown, engine, oil, smoke, turbo

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 04:26 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
| Home | Register | FAQ | Members List | Calendar | Today's Posts | Search | New Posts |